Автор Тема: Linux Acestream engine вопрос  (Прочитано 4826 раз)

assus

  • Newbie
  • *
  • Сообщений: 1
    • Просмотр профиля
Linux Acestream engine вопрос
« : Февраль 09, 2016, 20:41:16 »
Ребята никак немогу настроить, чтобы можно было подключится из внешней сети к движку...
На windows, поставил галочку "ALLOW REMOTE ACCESS:" и работает, а на линуксе как ?

Запускаю так:

root@ubuntu:~# acestreamengine --client-console --service-remote-access
2016-02-08 12:23:07,756|MainThread|acestream|platform=linux
2016-02-08 12:23:07,756|MainThread|acestream|app=acestream
2016-02-08 12:23:07,757|MainThread|acestream|version=3.0.3 code=3000300 revision=1355 date=2014-10-31
2016-02-08 12:23:07,757|MainThread|acestream|use_local_db=True
2016-02-08 12:23:07,757|MainThread|acestream|use_m2crypto=True
2016-02-08 12:23:07,758|MainThread|acestream|enable debug: 0
2016-02-08 12:23:07,758|MainThread|acestream|get_default_api_version: 2
2016-02-08 12:23:07,759|MainThread|acestream.coreapp|use fixed i2i_port: 62062
2016-02-08 12:23:07,784|MainThread|acestream.SocketHandler.InterruptSocket|bound on 127.0.0.1:36837
2016-02-08 12:23:07,785|MainThread|acestream.SocketHandler.SocketHandler|bind: socket bound: host=0.0.0.0 port=8621
2016-02-08 12:23:07,785|MainThread|acestream.LM|listen on 8621
2016-02-08 12:23:07,793|MainThread|acestream.VideoServer|start: addr=127.0.0.1 port=6878
2016-02-08 12:23:07,799|MainThread|acestream.SocketHandler.InterruptSocket|bound on 127.0.0.1:54024
2016-02-08 12:23:07,799|MainThread|acestream.SocketHandler.SocketHandler|bind: socket bound: host=127.0.0.1 port=62062
2016-02-08 12:23:07,804|Instance2InstanceThread-24|acestream.APIServer|run: ready to receive remote commands on 62062


И только по внутреннему IP даёт соединится, а по внешнему IP, никак. В чём проблема ?

Спасибо.

Wave

  • Newbie
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Linux Acestream engine вопрос
« Ответ #1 : Март 14, 2016, 17:00:19 »
Ребята никак немогу настроить, чтобы можно было подключится из внешней сети к движку...
На windows, поставил галочку "ALLOW REMOTE ACCESS:" и работает, а на линуксе как ?

Запускаю так:

root@ubuntu:~# acestreamengine --client-console --service-remote-access
2016-02-08 12:23:07,756|MainThread|acestream|platform=linux
2016-02-08 12:23:07,756|MainThread|acestream|app=acestream
2016-02-08 12:23:07,757|MainThread|acestream|version=3.0.3 code=3000300 revision=1355 date=2014-10-31
2016-02-08 12:23:07,757|MainThread|acestream|use_local_db=True
2016-02-08 12:23:07,757|MainThread|acestream|use_m2crypto=True
2016-02-08 12:23:07,758|MainThread|acestream|enable debug: 0
2016-02-08 12:23:07,758|MainThread|acestream|get_default_api_version: 2
2016-02-08 12:23:07,759|MainThread|acestream.coreapp|use fixed i2i_port: 62062
2016-02-08 12:23:07,784|MainThread|acestream.SocketHandler.InterruptSocket|bound on 127.0.0.1:36837
2016-02-08 12:23:07,785|MainThread|acestream.SocketHandler.SocketHandler|bind: socket bound: host=0.0.0.0 port=8621
2016-02-08 12:23:07,785|MainThread|acestream.LM|listen on 8621
2016-02-08 12:23:07,793|MainThread|acestream.VideoServer|start: addr=127.0.0.1 port=6878
2016-02-08 12:23:07,799|MainThread|acestream.SocketHandler.InterruptSocket|bound on 127.0.0.1:54024
2016-02-08 12:23:07,799|MainThread|acestream.SocketHandler.SocketHandler|bind: socket bound: host=127.0.0.1 port=62062
2016-02-08 12:23:07,804|Instance2InstanceThread-24|acestream.APIServer|run: ready to receive remote commands on 62062


И только по внутреннему IP даёт соединится, а по внешнему IP, никак. В чём проблема ?

Спасибо.

Вместо --client-console используйте --stream-source для проброса наружу --host ваш внешний IP порт по умолчанию 7764 либо выберите свой (должен быть открыт на роутере) порт 8621 не ставьте, с ним не работает, видимо так и должно быть, либо так случилось, спросить бы у кого))).